e
gga

frak.

TOOL TRACKING SYSTEM
INSTALLATION GUIDE

TTS Installation Guide



This document walks through the steps necessary for installing the program.

e You should have administrator rights on the local computer to install the software.

e |f you are using SQL Server Express Edition, see Appendix A and B.

e If you are using Microsoft SQL Server, see Appendix B.

e If you are going to use a real-time wireless handheld with the application, you cannot use the
Microsoft Access database option; you must use a SQL Server database. Real-time wireless
handhelds must be connected to the Wi-Fi on the same network as the machine hosting the SQL

database. Batch handhelds can use either database option.

e When you run the setup.exe file to install the application, you may get a message that indicates
some runtime files are out of date. Click the OK button to update the files.

1. Runsetup.exe.

2. Select the type of database you want to use. (The Microsoft SQL
Server option requires manual steps to install and configure the
database. Please Cancel the setup, perform the steps in
Appendix A and/or B, and then re-run this Setup.)

3. If you selected Microsoft SQL Server, enter the server settings.
When entering the SQL Server Name or IP Address, if you are
using a named instance, add it with a backslash (example:
myserver2\SQLExpress).
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¥ Tool Tracking System Setup

. Welcome
E : Welcome to the installr for Tool Tracking System 1.35.0.
Itis stronly recommendd that you ext al Windows programs
befors continuing with this instalation.
¥ Tool Tracking System Setup =
Database Type
Select an option and click Next to continue. 9|gatrak
Please sslect the database type you plan to use:
@ Microsoft Access
Microsoft SQL Server requires addiional steps)
Bock | [ MNea> | [ Concal
¥ Tool Tracking System Setup =
SQL Server Settings
Filinthe ftems below and diick Next to continue. gl g atrak
Please enter the following settings:
SQL Server Name or IP Address:
Database Name:
Bock | [ Met> | [ conce




4. Select the Installation Folder for the application. The default
folder is C:\GigaTrak\Tool Tracking System.
a. Ifinstalling to a network location, please make sure all

users have read and write access to the selected folder.
The installation will copy the application files to a shared
folder on your server. Please select the designated
shared folder to install the application to at this time.
Please see Appendix C for instructions on setting up the
network shared folder.

5. Select the Shortcut Folder. The default is GigaTrak. Select the
Next button and complete the installation.

6. For further installations of the software when using a network
location, navigate to the shared folder and run the setup.exe in
that folder. This set up will default to the path selected in step 4
of the first installation.

&) Tool Tracking System Setup

Installation Folder

=

Where would you like Tool Tracking System to be installed? gl gat rak
“The software wil be installed n the folder listed below. To select a diferent location, ether type in
new path, or cliek Change to browse for an existing folder.
Install Tool Tracking System to:
C\Giga Trak\Tool Tracking System Chenge
Space required: 417 MB
Space available on selected dive: 636.76 GB
Back | [ bet> | [ concm
¥ Tool Tracking System Setup =
Shortcut Folder
‘Whrs would you like th shortcuts to be instaled? g | g atrak
The shortcut icons will be created in the folder indicated belom. I you don't wari to use the default
folder, you can ether type anew name, or select an exisiing folder from the st
Shortcut Folder:
GigaTrak -
Instal shortcus for cumert user only
@ Make shortcuts avaizble to l users
ook | [ bes> | [ Concal

o -

To update the program from an exe, run the setup.exe. The updater should default to the correct installation path.

Please verify that the path is correct when running the update.
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Start the application by double-clicking on the Tool Tracking System icon located on the desktop. If you are
using a network location, only the first person to enter the system will need to follow these steps.

ACCESS INSTALLATION

The initial installation uses a demo database for you to train and learn with. We do NOT recommend using
this database when you are ready to start entering real data.

If you want to use the demo data, click the Register button. The Log In screen will default to the Demo User.
Click the Log In button to proceed. When you are ready to start entering real data, go to the File menu and
select Registration Form. Enter the Customer Ident code and License Key provided by GigaTrak, and click
the Register button. You will be prompted to use a clean database. Respond “Yes” to the prompt.

If you do not want to use the demo database, enter the Customer Ident code and License Key provided by
GigaTrak, and click the Register button. You will be prompted to use a clean database. Respond “Yes” to
the prompt.

SQL SERVER INSTALLATION

No demo data is provided with the SQL Server database. If the Registration screen does not appear, go to
the File menu and select Registration Form. On the Registration screen, enter the Customer Ident code and
the License Key provided by GigaTrak, and click the Register button.

ADDITIONAL PROGRAM INFORMATION

e Some functions, such as access to the Setup Options and Check for Update function, are restricted
to the administrator log in (user name - admin, password - adminuser).

e Add yourself as an employee. On the File menu, select Employee Administration. Select the Add
button. Enter your First Name, Last Name, and a Barcode. Also enter the Log in Name and
Password you will use to log in to the TTS application. In the Access Levels section, select Edit for all
items. This will give you edit rights to all functions in the application. Select the Save button when
you are finished.

e Proceed to the “GigaTrak TTS Quick Start” guide.

NOTE: Please assign barcodes to any imported data as soon as possible.

If any hardware (handheld computer, printer, etc.) was ordered, review the supplemental hardware
documentation.
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This document provides installation and configuration notes on installing a new instance of SQL Server 2008
R2 Express for use with GigaTrak software.

INSTALL SQL SERVER 2008 R2 EXPRESS:

10.
11.

12.

13.

14.

If not already installed, download and install the appropriate version of Microsoft Windows Installer
4.5 for your operating system from the following link:
http://www.microsoft.com/download/en/details.aspx?id=8483
If not already installed, download and install Microsoft .NET Framework 3.5 SP1 from the following
link: http://www.microsoft.com/download/en/details.aspx?id=22
If not already installed, download and install the appropriate version of Windows PowerShell 2.0
(part of the Windows Management Framework) for your operating system from the following link:
http://support.microsoft.com/kb/968929
Download the appropriate version of SQL Server 2008 R2 Express with tools (WT) for your operating
system from the following link: http://www.microsoft.com/en-us/download/details.aspx?id=30438

a. For 32-bit Windows, download SQLEXPRWT_x86_ENU.exe

b. For 64-bit Windows, download SQLEXPRWT_x64 ENU.exe
Launch the installer and wait for the files to unpack and the prerequisites to be verified. Click New
installation. Accept the license terms and click Next. (Please note: some of the screens below may
be skipped if they do not require any user interaction.)
On the Setup Support Rules screen, fix any Failed rules and Re-run the scan if necessary. (Please
note: Windows Firewall issues will be addressed later in this document.) Click Next.
On the Feature Selection screen, select Database Engine Services and Management Tools — Basic
and click Next. (SQL Client Connectivity SDK is not required).
(On the Installation Rules screen, fix any Failed rules and Re-run the scan if necessary. Click Next.)
On the Instance Configuration screen, select Default instance (unless it is already being used). Click
Next.
(On the Disk Space Requirements screen, click Next.)
On the Server Configuration screen, set the SQL Server Database Engine Account Name to NT
AUTHORITY\SYSTEM, and the SQL Server Browser Startup Type to Automatic. Click Next.
On the Database Engine Configuration screen, on the Account Provisioning tab, select Mixed Mode,
and enter a strong password for the system administrator (sa) account. Add any other users or
groups that need SQL Server administrator access. Click Next.
On the Error Reporting screen, click Next. The installation will probably begin automatically at this
point. If not, click Next until the install begins.
On the Complete screen, click Close. Also close the Installation Center.
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ENABLE TCP/IP:

w

Click Start, Programs, Microsoft SQL Server 2008 R2, Configuration Tools, SQL Server Configuration
Manager.

Expand SQL Server Network Configuration, and click on Protocols.

Double-click TCP/IP, and change Enabled to Yes. Click OK and OK again.

Close SQL Server Configuration Manager.

ADD FIREWALL EXCEPTIONS:

If you are running Windows Firewall or similar software firewall, you must make exceptions to allow
remote access to the SQL Server. Click Start, Settings, Control Panel. Double-click Windows
Firewall.

For Windows XP:
1. Click the Exceptions tab.
2. Click Add Program. Click Browse and select C:\Program Files\Microsoft SQL
Server\MSSQL10_50.MSSQLSERVER\MSSQL\Binn\sqlservr.exe. Click OK.
3. Click Add Program. Click Browse and select C:\Program Files\Microsoft SQL
Server\90\Shared\sqglbrowser.exe. Click OK. Click OK again.
For Windows 7:

1. Click Advanced Settings

2. Click Inbound Rules

3. Click New Rule.
a. Select Program, click Next
b. Click Browse to %Program Files%\Microsoft SQL

Server\MSSQL10_50.MSSQLSERVER\MSSQL\Binn\sqlservr.exe. Click Next.

c. Click Next (allow the connection).
d. Select Profiles, click Next
e. Name =SQL Server, click Finish

4. Click New Rule.
a. Select Program, click Next
b. Click Browse to %Program Files% (x86)\Microsoft SQL

Server\90\Shared\sglbrowser.exe. Click Next.

c. Click Next (allow the connection).
d. Select Profiles, click Next
e. Name =SQL Server Browser, click Finish

RESTART

1.

ukwn

Click Start=>Programs—>Microsoft SQL Server 2008 R2-> Configuration Tools=>SQL Server
Configuration Manager.

Click SQL Server Services

Right-Click SQL Server & click “restart”

Right-Click Server Browser & click “restart”

Close SQL Server Configuration Manager.
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The below tasks can all be accomplished with SQL Server Management Studio. Make note of the SQL
Server/instance nhame and the database name. These values will be required when you select the Microsoft
SQL Server option during the installation, and can also be changed later if needed by manually editing the
“win_tts.ini” file.
e Verify that your SQL Server authentication is set to SQL Server and Windows Authentication Mode.
To verify or change this setting, right-click your server (or instance), click Properties, and click
Security.
e Right-click Databases, and click New Database. Create a new database named “win_tts”. An
alternate database name can be used if desired. Click OK.
e Expand the main Security folder, right-click Logins, and click New Login. Create a new Login named
“tts_user” (all lower case letters), using SQL Server authentication, with a password of “gigatools”
(all lower case letters). Make sure to uncheck all check boxes relating to passwords. Set the default
database to win_tts. Before saving, continue to the next step.
e Under User Mapping, in the top box, check the Map checkbox next to the win_tts database. In the
bottom box, check to set database role memberships of db_datareader, db_datawriter and
db_ddladmin. Click OK to save the login.
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APPENDIX C SETUP THE NETWORK SHARED FOLDER

1. Create afolder on the network where you wish to store the GigaTrak application files.

2. Right Click on the newly created folder and Select Properties.

3. Click on the Security tab.

4. Click Edit.

5. Add all users and or user groups that will be using the GigaTrak
software

6. For each user and user group added, highlight the added user or user
group in the Group or user names. Then in the Permissions for User
section make sure both Read and Write boxes are check and click
Apply.
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General | Shaiing | Secuty | Previous Versions | Customize |

Object name:  \\ Networkfile\GigaTrak\Shared Folder\Giga Trak
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|, Permissions for GigaTrak

Security

Object name:  \\ Networkfile\Giga Trak'\Shared Folder\Giga Trak

Group or user names
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